const regex = /^(?:[0-9A-F]{1,2})(?:,[0-9A-F]{1,2})*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[0-9A-F]{1,2})(?:,[0-9A-F]{1,2})*$', 'gm')
const str = `1,2,3,4
A,B,C,D
10,11,12,13
10,AA,BB,CC
1,x
1
FF
FF,1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}