import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0-9A-F]{1,2})(?:,[0-9A-F]{1,2})*$";
final String string = "1,2,3,4\n"
+ "A,B,C,D\n"
+ "10,11,12,13\n"
+ "10,AA,BB,CC\n"
+ "1,x\n"
+ "1\n"
+ "FF\n"
+ "FF,1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}