using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[0-9A-F]{1,2})(?:,[0-9A-F]{1,2})*$";
string input = @"1,2,3,4
A,B,C,D
10,11,12,13
10,AA,BB,CC
1,x
1
FF
FF,1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}