#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)^GET\ (\/([^\s?#]+)?([?][^?#]*)?(#.*)?)?"
Local $sString = "GET /flussonic_event.php HTTP/1.1" & @CRLF & _
"GET /tnt/index.m3u8 HTTP/1.1" & @CRLF & _
"GET /tnt HTTP/1.1" & @CRLF & _
"GET /tnt/mpegts HTTP/1.1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")