// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sm)^GET\ (\/([^\s?#]+)?([?][^?#]*)?(#.*)?)?").unwrap();
let string = "GET /flussonic_event.php HTTP/1.1
GET /tnt/index.m3u8 HTTP/1.1
GET /tnt HTTP/1.1
GET /tnt/mpegts HTTP/1.1
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}