package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sm)^GET\ (\/([^\s?#]+)?([?][^?#]*)?(#.*)?)?`)
var str = `GET /flussonic_event.php HTTP/1.1
GET /tnt/index.m3u8 HTTP/1.1
GET /tnt HTTP/1.1
GET /tnt/mpegts HTTP/1.1
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}