using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[\[[a-zA-Z]*\:)";
string substitution = @"";
string input = @"[[File:Johann Sebastian Bach signature.svg|right|250px|alt=signature written in ink in a flowing script]]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}