import Foundation
let pattern = #"(\[\[[a-zA-Z]*\:)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[[File:Johann Sebastian Bach signature.svg|right|250px|alt=signature written in ink in a flowing script]]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}