// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\[\[[a-zA-Z]*\:)").unwrap();
let string = "[[File:Johann Sebastian Bach signature.svg|right|250px|alt=signature written in ink in a flowing script]]";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}