#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+)?(0|27)([5-9])([0-9])( )?([0-9]{3})( )?([0-9]{4})$"
Local $sString = "+27827860965" & @CRLF & _
"27827860965" & @CRLF & _
"0827860965" & @CRLF & _
"034567891" & @CRLF & _
"082 786 0965" & @CRLF & _
"+2782 786 0965" & @CRLF & _
"2782 786 0965"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")