using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"00:A0:50:([A-Fa-f0-9]{2}:){2}[A-Fa-f0-9]";
string input = @"00:A0:50:AB:CD:FF";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}