import re
regex = re.compile(r"00:A0:50:([A-Fa-f0-9]{2}:){2}[A-Fa-f0-9]")
test_str = "00:A0:50:AB:CD:FF"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")