$re = '/00:A0:50:([A-Fa-f0-9]{2}:){2}[A-Fa-f0-9]/';
$str = '00:A0:50:AB:CD:FF';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);