const regex = /00:A0:50:([A-Fa-f0-9]{2}:){2}[A-Fa-f0-9]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('00:A0:50:([A-Fa-f0-9]{2}:){2}[A-Fa-f0-9]', '')
const str = `00:A0:50:AB:CD:FF`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}