using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\s*meta\s
# using lookahead to capture type to $1
(?=[^>]*?
\b(?:name|property|http-equiv)\s*=\s*
(?|""\s*([^""]*?)\s*""|'\s*([^']*?)\s*'|
([^""'>]*?)(?=\s*/?\s*>|\s\w+\s*=))
)
# capture the content to $2
[^>]*?\bcontent\s*=\s*
(?|""\s*([^""]*?)\s*""|'\s*([^']*?)\s*'|
([^""'>]*?)(?=\s*/?\s*>|\s\w+\s*=))
[^>]*>
";
string input = @"<meta content = foo name = bar />
<meta name= bar sdf content= foo >
<meta content=""name"" name=""author"">
<meta name =""keywords"" content = "" php documentation "">
<meta name= ""DESCRIPTION"" content="" a php manual "">
<meta name=""geo.position"" content=""49.33;-86.59 "">
<meta content=' 49.33;-86.59' name = geo.position >";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}