import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\s*meta\\s\n\n"
+ "# using lookahead to capture type to $1\n"
+ "(?=[^>]*?\n"
+ " \\b(?:name|property|http-equiv)\\s*=\\s*\n"
+ " (?|\"\\s*([^\"]*?)\\s*\"|'\\s*([^']*?)\\s*'|\n"
+ " ([^\"'>]*?)(?=\\s*/?\\s*>|\\s\\w+\\s*=))\n"
+ ")\n\n"
+ "# capture the content to $2\n"
+ "[^>]*?\\bcontent\\s*=\\s*\n"
+ " (?|\"\\s*([^\"]*?)\\s*\"|'\\s*([^']*?)\\s*'|\n"
+ " ([^\"'>]*?)(?=\\s*/?\\s*>|\\s\\w+\\s*=))\n"
+ "[^>]*>\n";
final String string = "<meta content = foo name = bar />\n"
+ "<meta name= bar sdf content= foo >\n"
+ "<meta content=\"name\" name=\"author\">\n"
+ "<meta name =\"keywords\" content = \" php documentation \">\n"
+ "<meta name= \"DESCRIPTION\" content=\" a php manual \">\n"
+ "<meta name=\"geo.position\" content=\"49.33;-86.59 \">\n"
+ "<meta content=' 49.33;-86.59' name = geo.position >";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}