# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
<\s*meta\s
# using lookahead to capture type to $1
(?=[^>]*?
\b(?:name|property|http-equiv)\s*=\s*
(?|"\s*([^"]*?)\s*"|'\s*([^']*?)\s*'|
([^"'>]*?)(?=\s*/?\s*>|\s\w+\s*=))
)
# capture the content to $2
[^>]*?\bcontent\s*=\s*
(?|"\s*([^"]*?)\s*"|'\s*([^']*?)\s*'|
([^"'>]*?)(?=\s*/?\s*>|\s\w+\s*=))
[^>]*>
"""
test_str = ("<meta content = foo name = bar />\n"
"<meta name= bar sdf content= foo >\n"
"<meta content=\"name\" name=\"author\">\n"
"<meta name =\"keywords\" content = \" php documentation \">\n"
"<meta name= \"DESCRIPTION\" content=\" a php manual \">\n"
"<meta name=\"geo.position\" content=\"49.33;-86.59 \">\n"
"<meta content=' 49.33;-86.59' name = geo.position >")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.