using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=fruits\s)((?<count>\d{1,})\s(?<fruit>\w{1,},))";
string input = @"fruits 5 apples, 2 oranges, 3 bananas";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}