$re = '/(?<=fruits\s)((?<count>\d{1,})\s(?<fruit>\w{1,},))/i';
$str = 'fruits 5 apples, 2 oranges, 3 bananas';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);