const regex = /(?<=fruits\s)((?<count>\d{1,})\s(?<fruit>\w{1,},))/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=fruits\\s)((?<count>\\d{1,})\\s(?<fruit>\\w{1,},))', 'i')
const str = `fruits 5 apples, 2 oranges, 3 bananas`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}