re = /(?<=fruits\s)((?<count>\d{1,})\s(?<fruit>\w{1,},))/i
str = 'fruits 5 apples, 2 oranges, 3 bananas'
# Print the match result
str.match(re) do |match|
puts match.to_s
end