using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\[\]])|(;)|(\{(?=[a-zA-Z\s]))|((?<=[a-zA-Z\s])\})|(\{(?=\d))|((?<=\d)\})";
string input = @"Authors: [{Steven Brown}]; Dates: [{2010}]
Authors: [{John Hawk},{William Green},{Michael Ron}]; Dates: [{2001},{2002},{2003}]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}