import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\[\\]])|(;)|(\\{(?=[a-zA-Z\\s]))|((?<=[a-zA-Z\\s])\\})|(\\{(?=\\d))|((?<=\\d)\\})";
final String string = "Authors: [{Steven Brown}]; Dates: [{2010}]\n\n"
+ "Authors: [{John Hawk},{William Green},{Michael Ron}]; Dates: [{2001},{2002},{2003}]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}