$re = '/([\[\]])|(;)|(\{(?=[a-zA-Z\s]))|((?<=[a-zA-Z\s])\})|(\{(?=\d))|((?<=\d)\})/';
$str = 'Authors: [{Steven Brown}]; Dates: [{2010}]
Authors: [{John Hawk},{William Green},{Michael Ron}]; Dates: [{2001},{2002},{2003}]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);