const regex = /([\[\]])|(;)|(\{(?=[a-zA-Z\s]))|((?<=[a-zA-Z\s])\})|(\{(?=\d))|((?<=\d)\})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\[\\]])|(;)|(\\{(?=[a-zA-Z\\s]))|((?<=[a-zA-Z\\s])\\})|(\\{(?=\\d))|((?<=\\d)\\})', 'g')
const str = `Authors: [{Steven Brown}]; Dates: [{2010}]
Authors: [{John Hawk},{William Green},{Michael Ron}]; Dates: [{2001},{2002},{2003}]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}