use strict;
my $str = 'Hi, <name> pls visit <url>';
my $regex = qr/(?=<)|(?<=> )/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";