re = /(?=<)|(?<=> )/m
str = 'Hi, <name> pls visit <url>'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result