#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[\r?\n]"
Local $sString = "(2 months)" & @CRLF & _
"" & @CRLF & _
"ML"
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)