$re = '/[\r?\n]/';
$str = '(2 months)
ML';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;