import Foundation
let pattern = #"[\r?\n]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
(2 months)
ML
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)