#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^select (?:skip \d+\s+)?(?:first \d+\s+)?\* from X$"
Local $sString = "SELECT * FROM X" & @CRLF & _
"SELECT SKIP 1 FIRST 2 * FROM X" & @CRLF & _
"SELECT SKIP 1 * FROM X" & @CRLF & _
"SELECT FIRST 1 * FROM X"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")