package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^select (?:skip \d+\s+)?(?:first \d+\s+)?\* from X$`)
var str = `SELECT * FROM X
SELECT SKIP 1 FIRST 2 * FROM X
SELECT SKIP 1 * FROM X
SELECT FIRST 1 * FROM X`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}