re = /^select (?:skip \d+\s+)?(?:first \d+\s+)?\* from X$/im
str = 'SELECT * FROM X
SELECT SKIP 1 FIRST 2 * FROM X
SELECT SKIP 1 * FROM X
SELECT FIRST 1 * FROM X'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end