$re = '/^select (?:skip \d+\s+)?(?:first \d+\s+)?\* from X$/im';
$str = 'SELECT * FROM X
SELECT SKIP 1 FIRST 2 * FROM X
SELECT SKIP 1 * FROM X
SELECT FIRST 1 * FROM X';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);