#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)^[^']*\K'|'(?=[^']*$)"
Local $sString = "asdasd 'asdsad 'asdsad 'sadsad'asdasdasd"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)