const regex = /^[^']*\K'|'(?=[^']*$)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\']*\\K\'|\'(?=[^\']*$)', 'gim')
const str = `asdasd 'asdsad 'asdsad 'sadsad'asdasdasd`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);