$re = '/^[^\']*\K\'|\'(?=[^\']*$)/im';
$str = 'asdasd \'asdsad \'asdsad \'sadsad\'asdasdasd';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;