use strict;
my $str = 'asdasd \'asdsad \'asdsad \'sadsad\'asdasdasd';
my $regex = qr/^[^']*\K'|'(?=[^']*$)/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";