package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9a-fA-F]{1,4}:){7}[0-9a-fA-F]{1,4}`)
var str = `centos7
centos7.local
centos7.com.au
192.168.128.3
2001:8003:4c22:6701:e123:9395:629:8866`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}