re = /([0-9a-fA-F]{1,4}:){7}[0-9a-fA-F]{1,4}/m
str = 'centos7
centos7.local
centos7.com.au
192.168.128.3
2001:8003:4c22:6701:e123:9395:629:8866'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end