import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9a-fA-F]{1,4}:){7}[0-9a-fA-F]{1,4}";
final String string = "centos7\n"
+ "centos7.local\n"
+ "centos7.com.au\n"
+ "192.168.128.3\n"
+ "2001:8003:4c22:6701:e123:9395:629:8866";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}