#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(https?:\/\/)?(www.)?([\da-zA-z\_\-]+)\.(com|(|[\da-zA-Z]{2,6}))([\/\w \.\-\#\&\?\%\_]*)?([^\/| |\s])$"
Local $sString = "http://regex101.com/" & @CRLF & _
"http://regex101.com" & @CRLF & _
"http://www.regex101.com/" & @CRLF & _
"http://www.regex101.com" & @CRLF & _
"" & @CRLF & _
"https://regex101.com/" & @CRLF & _
"https://regex101.com" & @CRLF & _
"https://www.regex101.com/" & @CRLF & _
"https://www.regex101.com" & @CRLF & _
"" & @CRLF & _
"http://regex101.com/blahblahblahblahblah/" & @CRLF & _
"http://regex101.com/blahblahblahblahblah" & @CRLF & _
"http://www.regex101.com/blahblahblahblahblah/" & @CRLF & _
"http://www.regex101.com/blahblahblahblahblah" & @CRLF & _
"" & @CRLF & _
"https://regex101.com/blahblahblahblahblah/" & @CRLF & _
"https://regex101.com/blahblahblahblahblah" & @CRLF & _
"https://www.regex101.com/blahblahblahblahblah/" & @CRLF & _
"https://www.regex101.com/blahblahblahblahblah" & @CRLF & _
"" & @CRLF & _
"http://regex101.com/blahblahblahblahblah/blahblahblahblahblah/" & @CRLF & _
"http://regex101.com/blahblahblahblahblah/blahblahblahblahblah" & @CRLF & _
"http://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah/" & @CRLF & _
"http://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah" & @CRLF & _
"" & @CRLF & _
"https://regex101.com/blahblahblahblahblah/blahblahblahblahblah/" & @CRLF & _
"https://regex101.com/blahblahblahblahblah/blahblahblahblahblah" & @CRLF & _
"https://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah/" & @CRLF & _
"https://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://regex101.co.uk/" & @CRLF & _
"http://regex101.co.uk" & @CRLF & _
"http://www.regex101.co.uk/" & @CRLF & _
"http://www.regex101.co.uk" & @CRLF & _
"" & @CRLF & _
"https://regex101.co.uk/" & @CRLF & _
"https://regex101.co.uk" & @CRLF & _
"https://www.regex101.co.uk/" & @CRLF & _
"https://www.regex101.co.uk" & @CRLF & _
"" & @CRLF & _
"http://regex101.co.uk/blahblahblahblahblah/" & @CRLF & _
"http://regex101.co.uk/blahblahblahblahblah" & @CRLF & _
"http://www.regex101.co.uk/blahblahblahblahblah/" & @CRLF & _
"http://www.regex101.co.uk/blahblahblahblahblah" & @CRLF & _
"" & @CRLF & _
"https://regex101.co.uk/blahblahblahblahblah/" & @CRLF & _
"https://regex101.co.uk/blahblahblahblahblah" & @CRLF & _
"http://www.regex101.co.uk/blahblahblahblahblah/" & @CRLF & _
"http://www.regex101.co.uk/blahblahblahblahblah" & @CRLF & _
"" & @CRLF & _
"http://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/" & @CRLF & _
"http://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah" & @CRLF & _
"http://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/" & @CRLF & _
"http://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah" & @CRLF & _
"" & @CRLF & _
"https://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/" & @CRLF & _
"https://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah" & @CRLF & _
"https://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/" & @CRLF & _
"https://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah" & @CRLF & _
"" & @CRLF & _
"http://regex101.de/" & @CRLF & _
"http://regex101.de" & @CRLF & _
"http://www.regex101.de/" & @CRLF & _
"http://www.regex101.de" & @CRLF & _
"" & @CRLF & _
"https://regex101.de/" & @CRLF & _
"https://regex101.de" & @CRLF & _
"https://www.regex101.de/" & @CRLF & _
"https://www.regex101.de" & @CRLF & _
"" & @CRLF & _
"http://regex101.de/blahblahblahblahblah/" & @CRLF & _
"http://regex101.de/blahblahblahblahblah" & @CRLF & _
"http://www.regex101.de/blahblahblahblahblah/" & @CRLF & _
"http://www.regex101.de/blahblahblahblahblah" & @CRLF & _
"" & @CRLF & _
"https://regex101.de/blahblahblahblahblah/" & @CRLF & _
"https://regex101.de/blahblahblahblahblah" & @CRLF & _
"http://www.regex101.de/blahblahblahblahblah/" & @CRLF & _
"http://www.regex101.de/blahblahblahblahblah" & @CRLF & _
"" & @CRLF & _
"http://regex101.de/blahblahblahblahblah/blahblahblahblahblah/" & @CRLF & _
"http://regex101.de/blahblahblahblahblah/blahblahblahblahblah" & @CRLF & _
"http://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah/" & @CRLF & _
"http://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah" & @CRLF & _
"" & @CRLF & _
"https://regex101.de/blahblahblahblahblah/blahblahblahblahblah/" & @CRLF & _
"https://regex101.de/blahblahblahblahblah/blahblahblahblahblah" & @CRLF & _
"https://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah/" & @CRLF & _
"https://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")