re = /^(https?:\/\/)?(www.)?([\da-zA-z\_\-]+)\.(com|(|[\da-zA-Z]{2,6}))([\/\w \.\-\#\&\?\%\_]*)?([^\/| |\s])$/mi
str = 'http://regex101.com/
http://regex101.com
http://www.regex101.com/
http://www.regex101.com
https://regex101.com/
https://regex101.com
https://www.regex101.com/
https://www.regex101.com
http://regex101.com/blahblahblahblahblah/
http://regex101.com/blahblahblahblahblah
http://www.regex101.com/blahblahblahblahblah/
http://www.regex101.com/blahblahblahblahblah
https://regex101.com/blahblahblahblahblah/
https://regex101.com/blahblahblahblahblah
https://www.regex101.com/blahblahblahblahblah/
https://www.regex101.com/blahblahblahblahblah
http://regex101.com/blahblahblahblahblah/blahblahblahblahblah/
http://regex101.com/blahblahblahblahblah/blahblahblahblahblah
http://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah/
http://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah
https://regex101.com/blahblahblahblahblah/blahblahblahblahblah/
https://regex101.com/blahblahblahblahblah/blahblahblahblahblah
https://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah/
https://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah
http://regex101.co.uk/
http://regex101.co.uk
http://www.regex101.co.uk/
http://www.regex101.co.uk
https://regex101.co.uk/
https://regex101.co.uk
https://www.regex101.co.uk/
https://www.regex101.co.uk
http://regex101.co.uk/blahblahblahblahblah/
http://regex101.co.uk/blahblahblahblahblah
http://www.regex101.co.uk/blahblahblahblahblah/
http://www.regex101.co.uk/blahblahblahblahblah
https://regex101.co.uk/blahblahblahblahblah/
https://regex101.co.uk/blahblahblahblahblah
http://www.regex101.co.uk/blahblahblahblahblah/
http://www.regex101.co.uk/blahblahblahblahblah
http://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/
http://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah
http://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/
http://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah
https://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/
https://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah
https://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/
https://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah
http://regex101.de/
http://regex101.de
http://www.regex101.de/
http://www.regex101.de
https://regex101.de/
https://regex101.de
https://www.regex101.de/
https://www.regex101.de
http://regex101.de/blahblahblahblahblah/
http://regex101.de/blahblahblahblahblah
http://www.regex101.de/blahblahblahblahblah/
http://www.regex101.de/blahblahblahblahblah
https://regex101.de/blahblahblahblahblah/
https://regex101.de/blahblahblahblahblah
http://www.regex101.de/blahblahblahblahblah/
http://www.regex101.de/blahblahblahblahblah
http://regex101.de/blahblahblahblahblah/blahblahblahblahblah/
http://regex101.de/blahblahblahblahblah/blahblahblahblahblah
http://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah/
http://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah
https://regex101.de/blahblahblahblahblah/blahblahblahblahblah/
https://regex101.de/blahblahblahblahblah/blahblahblahblahblah
https://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah/
https://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end