import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?:\\/\\/)?(www.)?([\\da-zA-z\\_\\-]+)\\.(com|(|[\\da-zA-Z]{2,6}))([\\/\\w \\.\\-\\#\\&\\?\\%\\_]*)?([^\\/| |\\s])$";
final String string = "http://regex101.com/\n"
+ "http://regex101.com\n"
+ "http://www.regex101.com/\n"
+ "http://www.regex101.com\n\n"
+ "https://regex101.com/\n"
+ "https://regex101.com\n"
+ "https://www.regex101.com/\n"
+ "https://www.regex101.com\n\n"
+ "http://regex101.com/blahblahblahblahblah/\n"
+ "http://regex101.com/blahblahblahblahblah\n"
+ "http://www.regex101.com/blahblahblahblahblah/\n"
+ "http://www.regex101.com/blahblahblahblahblah\n\n"
+ "https://regex101.com/blahblahblahblahblah/\n"
+ "https://regex101.com/blahblahblahblahblah\n"
+ "https://www.regex101.com/blahblahblahblahblah/\n"
+ "https://www.regex101.com/blahblahblahblahblah\n\n"
+ "http://regex101.com/blahblahblahblahblah/blahblahblahblahblah/\n"
+ "http://regex101.com/blahblahblahblahblah/blahblahblahblahblah\n"
+ "http://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah/\n"
+ "http://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah\n\n"
+ "https://regex101.com/blahblahblahblahblah/blahblahblahblahblah/\n"
+ "https://regex101.com/blahblahblahblahblah/blahblahblahblahblah\n"
+ "https://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah/\n"
+ "https://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah\n\n\n\n"
+ "http://regex101.co.uk/\n"
+ "http://regex101.co.uk\n"
+ "http://www.regex101.co.uk/\n"
+ "http://www.regex101.co.uk\n\n"
+ "https://regex101.co.uk/\n"
+ "https://regex101.co.uk\n"
+ "https://www.regex101.co.uk/\n"
+ "https://www.regex101.co.uk\n\n"
+ "http://regex101.co.uk/blahblahblahblahblah/\n"
+ "http://regex101.co.uk/blahblahblahblahblah\n"
+ "http://www.regex101.co.uk/blahblahblahblahblah/\n"
+ "http://www.regex101.co.uk/blahblahblahblahblah\n\n"
+ "https://regex101.co.uk/blahblahblahblahblah/\n"
+ "https://regex101.co.uk/blahblahblahblahblah\n"
+ "http://www.regex101.co.uk/blahblahblahblahblah/\n"
+ "http://www.regex101.co.uk/blahblahblahblahblah\n\n"
+ "http://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/\n"
+ "http://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah\n"
+ "http://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/\n"
+ "http://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah\n\n"
+ "https://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/\n"
+ "https://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah\n"
+ "https://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/\n"
+ "https://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah\n\n"
+ "http://regex101.de/\n"
+ "http://regex101.de\n"
+ "http://www.regex101.de/\n"
+ "http://www.regex101.de\n\n"
+ "https://regex101.de/\n"
+ "https://regex101.de\n"
+ "https://www.regex101.de/\n"
+ "https://www.regex101.de\n\n"
+ "http://regex101.de/blahblahblahblahblah/\n"
+ "http://regex101.de/blahblahblahblahblah\n"
+ "http://www.regex101.de/blahblahblahblahblah/\n"
+ "http://www.regex101.de/blahblahblahblahblah\n\n"
+ "https://regex101.de/blahblahblahblahblah/\n"
+ "https://regex101.de/blahblahblahblahblah\n"
+ "http://www.regex101.de/blahblahblahblahblah/\n"
+ "http://www.regex101.de/blahblahblahblahblah\n\n"
+ "http://regex101.de/blahblahblahblahblah/blahblahblahblahblah/\n"
+ "http://regex101.de/blahblahblahblahblah/blahblahblahblahblah\n"
+ "http://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah/\n"
+ "http://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah\n\n"
+ "https://regex101.de/blahblahblahblahblah/blahblahblahblahblah/\n"
+ "https://regex101.de/blahblahblahblahblah/blahblahblahblahblah\n"
+ "https://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah/\n"
+ "https://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}