use strict;
my $str = 'http://regex101.com/
http://regex101.com
http://www.regex101.com/
http://www.regex101.com
https://regex101.com/
https://regex101.com
https://www.regex101.com/
https://www.regex101.com
http://regex101.com/blahblahblahblahblah/
http://regex101.com/blahblahblahblahblah
http://www.regex101.com/blahblahblahblahblah/
http://www.regex101.com/blahblahblahblahblah
https://regex101.com/blahblahblahblahblah/
https://regex101.com/blahblahblahblahblah
https://www.regex101.com/blahblahblahblahblah/
https://www.regex101.com/blahblahblahblahblah
http://regex101.com/blahblahblahblahblah/blahblahblahblahblah/
http://regex101.com/blahblahblahblahblah/blahblahblahblahblah
http://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah/
http://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah
https://regex101.com/blahblahblahblahblah/blahblahblahblahblah/
https://regex101.com/blahblahblahblahblah/blahblahblahblahblah
https://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah/
https://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah
http://regex101.co.uk/
http://regex101.co.uk
http://www.regex101.co.uk/
http://www.regex101.co.uk
https://regex101.co.uk/
https://regex101.co.uk
https://www.regex101.co.uk/
https://www.regex101.co.uk
http://regex101.co.uk/blahblahblahblahblah/
http://regex101.co.uk/blahblahblahblahblah
http://www.regex101.co.uk/blahblahblahblahblah/
http://www.regex101.co.uk/blahblahblahblahblah
https://regex101.co.uk/blahblahblahblahblah/
https://regex101.co.uk/blahblahblahblahblah
http://www.regex101.co.uk/blahblahblahblahblah/
http://www.regex101.co.uk/blahblahblahblahblah
http://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/
http://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah
http://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/
http://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah
https://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/
https://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah
https://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/
https://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah
http://regex101.de/
http://regex101.de
http://www.regex101.de/
http://www.regex101.de
https://regex101.de/
https://regex101.de
https://www.regex101.de/
https://www.regex101.de
http://regex101.de/blahblahblahblahblah/
http://regex101.de/blahblahblahblahblah
http://www.regex101.de/blahblahblahblahblah/
http://www.regex101.de/blahblahblahblahblah
https://regex101.de/blahblahblahblahblah/
https://regex101.de/blahblahblahblahblah
http://www.regex101.de/blahblahblahblahblah/
http://www.regex101.de/blahblahblahblahblah
http://regex101.de/blahblahblahblahblah/blahblahblahblahblah/
http://regex101.de/blahblahblahblahblah/blahblahblahblahblah
http://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah/
http://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah
https://regex101.de/blahblahblahblahblah/blahblahblahblahblah/
https://regex101.de/blahblahblahblahblah/blahblahblahblahblah
https://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah/
https://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah
';
my $regex = qr/^(https?:\/\/)?(www.)?([\da-zA-z\_\-]+)\.(com|(|[\da-zA-Z]{2,6}))([\/\w \.\-\#\&\?\%\_]*)?([^\/| |\s])$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}