using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w\s]+)#([\w\s]+)";
string input = @"& § POULET # Robert Man § | & § VAN MOUQUET # Jules § | 2eme § BERAUD # Henri § ! § | & § USTINOV # Peter § ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}