package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w\s]+)#([\w\s]+)`)
var str = `& § POULET # Robert Man § | & § VAN MOUQUET # Jules § | 2eme § BERAUD # Henri § ! § | & § USTINOV # Peter § `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}