re = /([\w\s]+)#([\w\s]+)/
str = '& § POULET # Robert Man § | & § VAN MOUQUET # Jules § | 2eme § BERAUD # Henri § ! § | & § USTINOV # Peter § '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end