$re = '/([\w\s]+)#([\w\s]+)/';
$str = '& § POULET # Robert Man § | & § VAN MOUQUET # Jules § | 2eme § BERAUD # Henri § ! § | & § USTINOV # Peter § ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);