using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(1[2-9]|[2-9][0-9]|[1-9][0-9][0-9]+)$";
string input = @"1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
20
21
30
99
100
101
299
5411
100000
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}